Uploaded image for project: 'MidPoint'
  1. MidPoint
  2. MID-1531

Repo ninja restore does not correctly restore organizational structure

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2 (Crius)
    • Fix Version/s: 2.2 (Crius)
    • Component/s: None
    • Labels:
      None
    • Environment:

      repo-ninja

      Description

      When importing previously backed up XML objects (Configure-Repository objects-Objects-Export all) using repo-ninja, the organizational structure is not imported correctly. It looks ok, the Organization objects are there, users are correctly linked to Organizations (parentOrgRef and assignment), but the Organization structure page does NOT show any users (only child Organization objects).

      Clicking Users - User details shows, hovewer, information regarding the org. structure. The user object is OK.

      The "fix" is to reimport the objects using midPoint "Import from file" feature.

      So it seems that something is wrong when re-creating db objects for Organizations using repo-ninja.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              vix Ivan Noris
              Reporter:
              vix Ivan Noris
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: