Uploaded image for project: 'MidPoint'
  1. MidPoint
  2. MID-2106

Using ScriptedSQL connector for connection to Postgres will fail with org.postgresql.util.PSQLException(Method org.postgresql.jdbc4.Jdbc4Connection.isValid(int) is not yet implemented.

    XMLWordPrintable

    Details

    • Git Revision:
      git-v3.0.1devel-683-ga0576c7

      Description

      This is caused by our postgres jdbc driver version in midPoint.
      We use/bundle postgresql-9.1-901.jdbc4.jar.

      Upgrading driver to postgresql-9.3-1102.jdbc41.jar helps, but as we bundle this driver, I need to stop midPoint, remove the file from WEB-INF/lib and replace by the newer version.

      Is there any specific reason for having the older driver?
      Or is there any workaround to use ScriptedSQL connector with the older driver for Postgres?

        Attachments

          Activity

            People

            Assignee:
            vix Ivan Noris
            Reporter:
            vix Ivan Noris
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: