Uploaded image for project: 'MidPoint'
  1. MidPoint
  2. MID-4318

Cannot make password required

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.7
    • Fix Version/s: 3.7
    • Component/s: None
    • Labels:
      None

      Description

      Even after setting security policy as

      <securityPolicy xmlns="http://midpoint.evolveum.com/xml/ns/public/common/common-3"
                      xmlns:q="http://prism.evolveum.com/xml/ns/public/query-3"
                      xmlns:c="http://midpoint.evolveum.com/xml/ns/public/common/common-3"
                      xmlns:t="http://prism.evolveum.com/xml/ns/public/types-3"
                      xmlns:org="http://midpoint.evolveum.com/xml/ns/public/common/org-3"
                      xmlns:icfs="http://midpoint.evolveum.com/xml/ns/public/connector/icf-1/resource-schema-3"
                      xmlns:ri="http://midpoint.evolveum.com/xml/ns/public/resource/instance-3"
                      oid="00000000-0000-0000-0000-000000000120"
                      version="3">
         <name>Default Security Policy</name>
         <credentials>
            <password>
               <minOccurs>1</minOccurs>
               <lockoutMaxFailedAttempts>3</lockoutMaxFailedAttempts>
               <lockoutFailedAttemptsDuration>PT3M</lockoutFailedAttemptsDuration>
               <lockoutDuration>PT15M</lockoutDuration>
               <valuePolicyRef xmlns:tns="http://midpoint.evolveum.com/xml/ns/public/common/common-3"
                               oid="00000000-0000-0000-0000-000000000003"
                               relation="org:default"
                               type="tns:ValuePolicyType"><!-- Default Password Policy --></valuePolicyRef>
            </password>
         </credentials>
      </securityPolicy>
      

      and value policy as

      <valuePolicy xmlns="http://midpoint.evolveum.com/xml/ns/public/common/common-3"
                   xmlns:q="http://prism.evolveum.com/xml/ns/public/query-3"
                   xmlns:c="http://midpoint.evolveum.com/xml/ns/public/common/common-3"
                   xmlns:t="http://prism.evolveum.com/xml/ns/public/types-3"
                   xmlns:org="http://midpoint.evolveum.com/xml/ns/public/common/org-3"
                   xmlns:icfs="http://midpoint.evolveum.com/xml/ns/public/connector/icf-1/resource-schema-3"
                   xmlns:ri="http://midpoint.evolveum.com/xml/ns/public/resource/instance-3"
                   oid="00000000-0000-0000-0000-000000000003"
                   version="2">
         <name>Default Password Policy</name>
         <stringPolicy>
            <description>Testing string policy</description>
            <limitations>
               <minLength>5</minLength>
               <minUniqueChars>3</minUniqueChars>
               <checkAgainstDictionary>true</checkAgainstDictionary>
               <checkPattern/>
            </limitations>
         </stringPolicy>
         <minOccurs>1</minOccurs>
      </valuePolicy>
      

      I am still able to create a user with no password.

        Attachments

          Activity

            People

            • Assignee:
              mederly Pavol Mederly
              Reporter:
              mederly Pavol Mederly
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: