Uploaded image for project: 'MidPoint'
  1. MidPoint
  2. MID-5214

Full text search stops working after upgrade

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.7.2, 3.8
    • Fix Version/s: 3.8.1
    • Component/s: GUI, Model
    • Labels:
    • Environment:

      After upgrade from 3.7.2 to 3.8

    • Subscription:
      Active subscription
    • Milestone:
      M3

      Description

      After initial setup of full text search on 3.7.2 it worked like a charm. We've recently upgraded to 3.8 and suddenly the search stopped working - but only for users.

      There is no trace of anything when looking at the logs and reindexing button at config doesn't help.

      What we found out, however, is that when we create a new user he gets indexed and when we modify an old user he also gets re-indexed.

      So right now, our workaround is that we need to modify every user after upgrade to get the full text search on users running properly (by copying the value from deprecated employeeType to new subType).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                johny Jan Minarciny
                Reporter:
                johny Jan Minarciny
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: