Uploaded image for project: 'MidPoint'
  1. MidPoint
  2. MID-6192

Handling of blank items in GUI is broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 4.1
    • Fix Version/s: 4.1
    • Component/s: None
    • Labels:
      None
    • Subscription:
      Internal

      Description

      How to replicate: Create a new user, fill-in only the name, and save.

      The result:

      <user ...>
          <name>test007</name>
          <documentation/>
          <subtype/>
          <metadata>...</metadata>
          <operationExecution>...</operationExecution>
          <assignment>...from template...</assignment>
          <iteration>0</iteration>
          <iterationToken/>
          <roleMembershipRef>...</roleMembershipRef>
          <activation>...</activation>
          <costCenter/>
          <emailAddress/>
          <telephoneNumber/>
          <employeeNumber/>
      </user> 

      Similar - wrong - behavior occurs when creating object policy (i.e. template) in system configuration. The subtype is empty, causing template to be not applied.

        Attachments

          Activity

            People

            Assignee:
            mederly Pavol Mederly
            Reporter:
            mederly Pavol Mederly
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: